Đề Xuất 11/2022 # Cấu Hình Switch Port, Vlans, Trunk, Vtp, Intervlan Routing / 2023 # Top 14 Like | Welovelevis.com

Đề Xuất 11/2022 # Cấu Hình Switch Port, Vlans, Trunk, Vtp, Intervlan Routing / 2023 # Top 14 Like

Cập nhật nội dung chi tiết về Cấu Hình Switch Port, Vlans, Trunk, Vtp, Intervlan Routing / 2023 mới nhất trên website Welovelevis.com. Hy vọng thông tin trong bài viết sẽ đáp ứng được nhu cầu ngoài mong đợi của bạn, chúng tôi sẽ làm việc thường xuyên để cập nhật nội dung mới nhằm giúp bạn nhận được thông tin nhanh chóng và chính xác nhất.

Yêu cầu:

Cấu hình trung kế:

Cấu hình trung kế Dot1q kết nối giữa Switch – Switch.

Cấu hình trung kế Dot1q kết nối giữa Switch – Router.

Cấu hình VTP:

Mỗi nhóm cấu hình VTP theo các yêu cầu sau:

VTP domain: BCMSNx (x là số thứ tự của nhóm, x = 1,2,3).

VTP pass: CISCO (lưu ý chữ hoa chữ thường).

SWx1 là VTP server.

SWx2, SWx3 là VTP client.

Cấu hình VLANs:

Mỗi nhóm tạo 3 VLANs tương ứng với mô hình trên

Ví dụ: nhóm 1 tạo VLAN11, VLAN12, VLAN13.

Gán port vào VLAN như sau:

x là số thứ tự của nhóm (x = 1,2,3).

Cấu hình định tuyến giữa các VLAN:

Mỗi nhóm cấu hình để 3 VLAN trong mỗi nhóm có thể ping thấy nhau.

Mỗi nhóm cấu hình giao thức định tuyến OSPF để tất cả VLAN và Interface Loopback có thể ping thấy nhau.

  Gợi ý:

2a: Dùng lệnh sau trên switch trong mode interface:

Switch(config-if)# switchport trunk encapsulation dot1q

Switch(config-if)# switchport mode trunk

!Lưu ý: phải gõ lệnh “switchport trunk encapsulation dot1q” trước lệnh “switchport mode trunk”, nếu gõ theo thứ tự ngược lại sẽ không thể tạo kết nối trung kế thành công

2b: Dùng lệnh sau trên router để cấu hình trung kế dot1q:

Router(config)# interface fastethernet 0/0.11

Router(config-if)# encapsulation dot1q 10

Router(config-if)# ip address 192.168.1.1 255.255.255.0

!lưu ý: câu lệnh trên tạo subinterface f0/0.11, chỉ định encapsulation là dot1q, thuộc VLAN 10 và có IP 192.168.1.1.

3: Dùng lệnh sau để cấu hình VTP:

Switch(config)# vtp domain BCMSN

Switch(config)# vtp password CISCO

4: Dùng các lệnh sau để cấu hình VLAN:

Switch(config)# vlan 10

Switch(config-vlan)# name VLAN10                       !ßđặt tên là VLAN10

Switch(config)# interface range fastethernet 0/1 – 6

Switch(config-if-range)# switchport mode access

Switch(config-if-range)# switchport access vlan 10        

Cấu hình đầy đủ:

!Nhóm 1:

!SW11:

! configure terminal

! interface fastEthernet0/8

switchport trunk encapsulation dot1q

switchport mode trunk

! interface fastEthernet0/9

switchport trunk encapsulation dot1q

switchport mode trunk

! interface fastEthernet0/24

switchport trunk encapsulation dot1q

switchport mode trunk

! vtp domain BCMSN1

vtp pass CISCO

! vlan 11

name VLAN11

! vlan 12

name VLAN12

! vlan 13

name VLAN13

! interface range fastEthernet0/1 – 7

switchport mode access

switchport access vlan 11

! interface range fastEthernet0/10 – 16

switchport mode access

switchport access vlan 12

! int range fastEthernet0/17 – 23

switchport mode access

switchport access vlan 13

! end

!SW12:

! configure terminal

! interface fastEthernet0/8

switchport trunk encapsulation dot1q

switchport mode trunk

! vtp mode client

vtp domain BCMSN1

vtp pass CISCO

! interface range fastEthernet0/1 – 7

switchport mode access

switchport access vlan 11

! interface range fastEthernet0/9 – 16

switchport mode access

switchport access vlan 12

! interface range fastEthernet0/17 – 24

switchport mode access

switchport access vlan 13

! end

SW13:

configure terminal

! interface fastEthernet0/8

switchport trunk encapsulation dot1q

switchport mode trunk

! vtp mode client

vtp domain BCMSN1

vtp pass CISCO

! interface range fastEthernet0/1 – 7

switchport mode access

switchport access vlan 11

! interface range fastEthernet0/10 – 16

switchport mode access

switchport access vlan 12

! interface range fastEthernet0/17 – 24

switchport mode access

switchport access vlan 13

! end

!R11:

configure terminal

! interface loopback0

ip address 1.1.1.1 255.255.255.0

! interface serial0/0

clock rate 64000

ip address 192.168.1.1 255.255.255.0

no shutdown

! interface fastEthernet0/0

no shutdown

! interface fastEthernet0/0.11

encapsulation dot1q 11

ip address 172.16.1.1 255.255.255.0

! interface fastEthernet0/0.12

encapsulation dot1q 12

ip address 172.16.2.1 255.255.255.0

! interface fastEthernet0/0.13

encapsulation dot1q 13

ip address 172.16.3.1 255.255.255.0

! router ospf 1

network 0.0.0.0 255.255.255.255 are 0

! end      

!Nhóm 2:

SW21:

! configure terminal

! interface fastEthernet0/8

switchport trunk encapsulation dot1q

switchport mode trunk

! interface fastEthernet0/9

switchport trunk encapsulation dot1q

switchport mode trunk

! interface fastEthernet0/24

switchport trunk encapsulation dot1q

switchport mode trunk

! vtp domain BCMSN2

vtp pass CISCO

! vlan 21

name VLAN21

! vlan 22

name VLAN22

! vlan 23

name VLAN23

! interface range fastEthernet0/1 – 7

switchport mode access

switchport access vlan 21

! interface range fastEthernet0/10 – 16

switchport mode access

switchport access vlan 22

! interface range fastEthernet0/17 – 23

switchport mode access

switchport access vlan 23

! end  

SW22:

! configure terminal

! interface fastEthernet0/8

switchport trunk encapsulation dot1q

switchport mode trunk

! vtp domain BCMSN2

vtp mode client

vtp pass CISCO

! interface range fastEthernet0/1 – 7

switchport mode access

switchport access vlan 21

! interface range fastEthernet0/9 – 16

switchport mode access

switchport access vlan 22

! interface range fastEthernet0/17 – 24

switchport mode access

switchport access vlan 23

! end  

SW23:

! configure terminal

! interface fastEthernet0/8

switchport trunk encapsulation dot1q

switchport mode trunk

! vtp domain BCMSN2

vtp mode client

vtp pass CISCO

! interface range fastEthernet0/1 – 7

switchport mode access

switchport access vlan 21

! interface range fastEthernet0/9 – 16

switchport mode access

switchport access vlan 22

! interface range fastEthernet0/17 – 24

switchport mode access

switchport access vlan 23

! end  

R21:

! configure terminal

! interface loopback0

ip address 2.2.2.2 255.255.255.0

! interface serial0/0

clock rate 64000

ip address 192.168.1.2 255.255.255.0

no shutdown

! interface serial0/1

clock rate 64000

ip address 192.168.2.2 255.255.255.0

no shutdown

! interface fastEthernet0/0

no shutdown

! interface fastEthernet0/0.21

encapsulation dot1q 21

ip address 172.17.1.1 255.255.255.0

! interface fastEthernet0/0.22

encapsulation dot1q 22

ip address 172.17.2.1 255.255.255.0

! interface fastEthernet0/0.23

encapsulation dot1q 23

ip address 172.17.3.1 255.255.255.0

! router ospf 1

network 0.0.0.0 255.255.255.255 are 0

! end      

!Nhóm 3:

SW31:

! configure terminal

! interface fastEthernet0/8

switchport trunk encapsulation dot1q

switchport mode trunk

! interface fastEthernet0/9

switchport trunk encapsulation dot1q

switchport mode trunk

! interface fastEthernet0/24

switchport trunk encapsulation dot1q

switchport mode trunk

! vtp domain BCMSN3

vtp pass CISCO

! vlan 31

name VLAN31

! vlan 32

name VLAN32

! vlan 33

name VLAN33

! interface range fastEthernet0/1 – 7

switchport mode access

switchport access vlan 31

! interface range fastEthernet0/10 – 16

switchport mode access

switchport access vlan 32

! interface range fastEthernet0/17 – 23

switchport mode access

switchport access vlan 33

! end  

SW32:

! configure terminal

! interface fastEthernet0/8

switchport trunk encapsulation dot1q

switchport mode trunk

! vtp mode client

vtp domain BCMSN3

vtp pass CISCO

! interface range fastEthernet0/1 – 7

switchport mode access

switchport access vlan 31

! interface range fastEthernet0/9 – 16

switchport mode access

switchport access vlan 32

! interface range fastEthernet0/17 – 24

switchport mode access

switchport access vlan 33

! end    

SW33:

! configure terminal

! interface fastEthernet0/8

switchport trunk encapsulation dot1q

switchport mode trunk

! vtp mode client

vtp domain BCMSN3

vtp pass

CISCO

! interface range fastEthernet0/1 – 7

switchport mode access

switchport access vlan 31

! interface range fastEthernet0/9 – 16

switchport mode access

switchport access vlan 32

! interface range fastEthernet0/17 – 24

switchport mode access

switchport access vlan 33

! end

R31:

configure terminal

! interface loop 0

ip address 3.3.3.3 255.255.255.0

! interface s0/0

clock rate 64000

ip address 192.168.2.3 255.255.255.0

no shutdown

! interface fastEthernet0/0

no shutdown

! interface fastEthernet0/0.31

encapsulation dot1q 31

ip address 172.18.1.1 255.255.255.0

! interface fastEthernet0/0.32

encapsulation dot1q 32

ip address 172.18.2.1 255.255.255.0

! interface fastEthernet0/0.33

encapsulation dot1q 33

ip address 172.18.3.1 255.255.255.0

! router ospf 1

network 0.0.0.0 255.255.255.255 are 0 !

end      

!kiem tra trunk

#show int trunk  

!kiem tra vtp

#show vtp status

 !kiem tra routing table

#show ip route

Cách Tạo Vlan, Chia Vlan Cho Các Thiết Bị Mạng Switch Cisco / 2023

Hướng dẫn cách tạo vlan, xóa vlan, chia vlan cho các thiết bị mạng switch CISCO trên packet tracer

Hướng dẫn cách tạo vlan, chia vlan, cho các thiết bị mạng switch CISCO

Sử dụng switch Cisco 2950 trong packet tracer để thực hành. Đầu tiên ta phải kiểm tra xem tất cả các port của switch đang thuộc vlan nào.

Switch# show vlan

Ta thấy Switch này có 24 port, các port từ 1 đến 24 đều chung vlan 1. Vlan 1 là vlan mặc định của tất cả các switch, khi chưa cấu hình thì các port của switch mặc định thuộc vlan này. Các máy tính nối đến switch thông với nhau bởi vì đều ở trên cùng vlan 1 này. Mình nối 4 PC vào switch này và đặt địa chỉ IP lần lượt cho 4 PC từ địa chỉ 192.168.1.1 đến 192.168.1.4. Khi chưa tạo vlan mình thực hiện ping từ PC 1 đến 3 PC còn lại thì 4 PC đều thông nhau.

Giờ mình bắt đầu tạo thêm các vlan mới cho switch mình tạo thêm 2 vlan mới là vlan 10 và vlan 20.

Switch# configure terminal

Switch(config)#vlan 10 ( tạo vlan 10)

Switch(config-vlan)#name ketoan ( đặt tên cho vlan 10 là ketoan)

Switch(config-vlan)#exit

Switch(config)#vlan 20 ( tạo vlan 20)

Switch(config-vlan)#name kythuat ( đặt tên cho vlan 20 là kythuat)

Gõ Exit để quay trở lại mode Switch# sử dụng lại câu lệnh show vlan để xem kết quả tạo vlan

Vậy là ta đã tạo được 2 vlan mới rồi nếu trong quá trình tạo mà muốn xóa bớt đi vlan thì tại sử dụng lệnh sau: Switch (config)# no vlan 10 thì vlan 10 sẽ bị xóa khỏi Switch.

Tiếp theo mình tiến hành gán port cho Switch vào các vlan khác nhau: PC 1 và 2 nằm trên 2 port F0/1 và F0/2 mình muốn nó vào chung một vlan 10 là vlan cho nhân viên kế toán thì sẽ phải chuyển 2 port F0/1 và F0/2 vào vlan 10.

Switch(config)#interface range F0/1-F0/2

Switch(config-if-range)#switchport access vlan 10

Mình tiếp tục gán PC 3 vào vlan 20 , PC3 thuộc port F0/3 của Switch ta lại tiếp tục cấu hình trên Switch

Switch(config)#interface F0/3

Switch(config-if-range)#switchport access vlan 20

PC4 mình vẫn để nó thuộc vlan mặc định là vlan1 nên port F0/4 của Switch mình không gán vào vlan nào hết.

Sau khi gán xong thì kết quả là PC1 và PC2 nối vào 2 port Switch chung vlan 10 nên ping sẽ thông nhau, còn PC3 và PC4 thuộc vlan 1 và vlan 20 nên không thể ping đến nhau và đến PC1 và PC2 trên vlan 10. Nếu muốn PC3 và PC4 ping thông thì bạn lại gán PC4 vào vlan 20.

Giờ mình tiến hành ping trên PC1 đến PC2 thành công nhưng từ PC1 đến PC3 thất bại vì khác vlan

Ping từ PC3 thuộc vlan 20 đến PC4 thuộc vlan 1 cũng thất bại

Việc chia Vlan là rất hữu ích trong việc giúp băng thông mạng được cải thiện khi có số lượng lớn máy tính kết nối đến Switch vì mỗi 1 vlan là 1 vùng Broadcast khác nhau nếu học giao thức ARP bạn sẽ hiểu rõ hơn tác dụng của nó. Bài sau mình xin hướng dẫn các bạn cấu hình router vlan routing để các vlan khác nhau có thể ping thông nhau qua thiết bị router layer 3.

Cấu Hình Router Trong Cisco / 2023

I. Cấu hình Route

1. Chế độ giao tiếp dòng lệnh CLI

Các câu lệnh được sử dụng trong chế độ cấu hình toàn cục là những câu lệnh có tác động lên toàn bộ hệ thống. Bạn sử dụng câu lệnh sau để di chuyển vào chế độ cấu hình toàn cục:

Chú ý: Sự thay đổi của dấu nhắc cho biết bạn đang ở chế độ cấu hình toàn cục.

Chế độ cấu hình toàn cục là chế độ cấu hình chính. Từ chế độ này bạn có thể chuyển vào các chế độ chuyên biệt như:

Chế độ cấu hình cổng giao tiếp.

Chế độ cấu hình đường truy cập.

Chế độ cấu hình router.

Chế độ cấu hình cổng con.

Chế độ cấu hình bộ điều khiển.

Bạn dùng lệnh exit để trở về chế độ cấu hình toàn cục hoặc bạn dùng phím Ctrl-Z để quay về thẳng chế độ EXEC đặc quyền.

2. Đặt tên cho router

Công việc đầu tiên khi cấu hình router là đặt tên cho router. Trong chế độ cấu hình toàn cục, bạn dùng lệnh sau:

Ngay sau khi bạn nhấn phím Enter để thực thi câu lệnh bạn sẽ thấy dấu nhắc đổi từ tên mặc định () sang tên mà bạn vừa mới đặt ( HocMangMayTinh ).

3. Đặt mật mã cho router

Mật mã được sử dụng để hạn chế việc truy cập vào router. Thông thường ta luôn đặt mật mã cho đường vty và console trên router. Ngoài ra mật mã còn được sử dụng để kiểm soát sự truy cập vào chế độ EXEC đặc quyền trên router. Khi đó, chỉ những người nào được phép mới có thể thực hiện việc thay đổi tập tin cấu hình trên router.

Đôi khi bạn sẽ thấy là rất không an toàn khi mật mã được hiển thị rõ ràng khi sử dụng lệnh hoặc . Để tránh điều này bạn nên dùng lệnh sau để mã hóa tất cả các mật mã hiển thị trên tập tin cấu hình của router:

Lệnh sẽ áp dụng một cơ chế mã hóa đơn giản lên tất cả các mật mã chưa được mã hóa. Riêng mật mã thì sử dụng một thuật toán mã hóa rất mạnh là MD5.

Chúng ta có rất nhiều lệnh show được dùng để kiểm tra nội dung các tập tin trên router và để tìm ra sự cố. Trong cả hai chế độ EXEC đặc quyền và EXEC người dùng, khi bạn gõ show? Thì bạn sẽ xem được danh sách các lệnh show. Đương nhiên là số lệnh show dùng được trong chế độ EXEC đặc quyền sẽ nhiều hơn trong chế độ EXEC người dùng.

Show interface – hiển thị trạng thái của tất cả các cổng giao tiếp trên router. Để xem trạng thái của một cổng nào đó thì bạn thêm tên và số thứ tự của cổng đó sau lệnh show interface. Ví dụ như: Router#show interface serial 0/1

Show controllers serial – hiển thị các thông tin chuyên biệt về phần cứng của các cổng serial.

Show clock – hiển thị đồng hồ được cài đặt trên router.

Show hosts – hiển thị danh sách tên và địa chỉ tương ứng.

Show users – hiển thị tất cả các user đang kết nối vảo router.

Show history – hiển thị danh sách các câu lệnh vừa mới được sử dụng.

Show flash – hiển thị thông tin bộ nhớ flash và tập tin IOS chứa trong đó.

Show version – hiển thị thông tin về router và IOS đang chạy trên RAM.

Show ARP – hiển thị bảng ARP trên router.

Show protocol – hiển thị trạng thái toàn cục và trạng thái của các cổng giao tiếp đã được cấu hình giao thức lớp 3.

Show startup-configuration – hiển thị tập tin cấu hình đang chạy trên RAM.

5. Cấu hình cổng serial

Vào chế độ cấu hình toàn cục.

Vào chế độ cấu hình cổng serial.

Khai báo địa chỉ và subnet mask.

Đặt tốc độ clock nếu đầu cáp cắm vào cổng serial là DCE. Nếu đầu cáp là DTE thì chúng ta có thể bỏ qua này.

Khởi động serial.

Mỗi một cổng serial đều phải có một địa chỉ IP và subnet mask để chúng có thể định tuyến các gói IP. Để cấu hình địa chỉ IP chúng ta dùng lệnh sau:

Cổng serial cần phải có tín hiệu clock để điều khiển thời gian thực hiện thông tin liên lạc. Trong hầu hết các trường hợp, thiết bị DCE, ví dụ như CSU, sẽ là thiết bị cung cấp tín hiệu clock. Mặc định thì Cisco router lad thiết bị DTE nhưng chúng ta có thể cấu hình chúng thành thiết bị DCE.

Mặc định thì các cổng giao tiếp trên router đều đóng. Nếu bạn muốn mở hay khởi động các cổng này thì bạn phải dùng lệnh no shutdown. Nếu bạn muốn đóng cổng lại để bảo trì hoặc xử lý sự cố thì bạn dùng lệnh shutdown.

Router(config)#interface serial 0/0 Router(config-if)#clock rate 56000 Router(config-if)#no shutdown

6. Thực hiện thêm, xóa, di chuyển và thay đổi tập tin cấu hình

Nếu bạn cần chỉnh sửa tập tin cấu hình thì bạn phải di chuyển vào đùng chế độ cấu hình và thực hiện cần thiết. Ví dụ: nếu bạn cần mở một cổng nào đó trên router thì trước hết bạn phải vào chế độ cấu hình toàn cục, sau đó vào chế độ cấu của cổng đó rồi dùng lệnh no shutdown.

Để kiểm tra những gì mà bạn vừa mới thay đổi, bạn dùng lệnh show runningconfig. Lệnh này sẽ hiển thị nội dung của tập tin cấu hình hiện tại. Nếu kết quả hiển thị có những có những chi tiết không đúng thì bạn có thể chỉnh sửa lại bằng cách thực hiện một hoặc nhiều cách sau:

Dùng dạng no của các lệnh cấu hình.

Khởi động lại router với tập tin cấu hình nguyên thuỷ trong NVRAM.

Chép tập tin cấu hình dự phòng từ TFTP server.

Xoá tập tin cấu hình khởi động bằng lệnh erase startup-config, sau đó khởi động lại router và vào chế độ cài đặt.

Để lưu tập tin, cấu hình hiện tại thành tập tin cấu hình khởi động lưu trong NVRAM, bạn dùng lệnh như sau:

Router#copy running-config startup-config

7. Cấu hình cổng Ethernet

Tương tự như cổng serial, chúng ta có thể cấu hình cổng Ethernet bằng đường console hoặc vty.

Mỗi cổng Ethernet cũng cần phải có một địa chỉ IP và subnet mask để có thể thực hiện định tuyến các gói IP qua cổng đó.

Vào chế độ cấu hình toàn cục.

Vào chế độ cấu hình cổng Ethernet.

Khai báo địa chỉ và subnet mask.

Khởi động cổng Ethernet.

Măc định là các cổng trên router đều đóng. Do đó, bạn phải dùng lệnh no shutdown để mở hay khởi động cổng. Nếu bạn cần đóng cổng lại để bảo trì hay xử lý sự cố thì bạn dùng lệnh shutdown.

1. Tầm quan trọng của việc chuẩn hoá tập tin cấu hình

Trong một tổ chức việc phát các quy định dành cho các tập tin cấu hình là rất cần thiết. Từ đó ta có thể kiểm soát được các tập tin nào càn bảo trì, lưu các tập tin ở đâu và như thế nào.

Các quy định này có thể là những quy định được ứng dụng rộng rái hoặc cũng có thể chỉ có giá trị trong một phạm vi nào đó. Nếu không có một quy định chung cho tổ chức của mình thì hệ thống mạng của bạn sẽ trở nên lộn xộn và không đảm bảo được hoạt động thông suốt.

2. Câu chú thích cho các cổng giao tiếp

Trên các cổng giao tiếp bạn nên ghi chú lại một số thông tin quan trọng, ví dụ như chỉ số mạch mà cổng này kết nối vào, hay thông tin vào router khác, về phân đoạn mạng mà cổng này kết nối đến. Dựa vào các câu chú thích này, người quản trị mạng có thể biết được là cổng giao tiếp này kết nối vào đâu.

3. Cấu hình chú thích cho các cổng giao tiếp

Trước tiên bạn phải vào chế độ cấu hình toàn cục. Rồi từ chế độ cấu hình toàn cục bạn chuyển vào chế độ cấu hình cổng giao tiếp. Tại đây bạn gõ lệnh description và câu chú thích mà bạn muốn.

Vào chế độ cấu hình toàn cục bằng lệnh configure terminal.

Vào chế độ cấu hình cổng giao tiếp (ví dụ là cổng Ethernet 0): interface Ethernet 0.

Nhập lệnh description và theo sau là câu chú thích.

Thoát khỏi chế độ cấu hình giao tiếp để trở về chế độ EXEC đăc quyền bằng cách nhấn phím Ctrl-Z.

Lưu lại cấu hình vừa rồi vào NVRAM bằng lệnh copy running-config startupconfig.

Router#config terminal Enter configuration commands, one per line. End with CNTL_Z Router (config)# interface Ethernet 0 Router (config-if)#description LAN Engineerinng, Bldg. 2

4. Thông điệp đăng nhập

Thông điệp đăng nhập được hiển thị khi bạn đăng nhập vào hệ thống. Loại thông điệp này rất hữu dụng khi bạn cần cảnh báo trước khi đến giờ tắt hệ thống mạng. Tất cả mọi người đều có thể nhìn thấy thông điệp đăng nhập. Cho nên bạn nên dùng các thông điệp mạng tính cảnh báo, thu hút sự chú ý. Còn những thông điệp để “chào đón” mọi người đăng nhập vào router là không thích hợp lắm. Ví dụ một thông điệp như sau: ” This is a secure system, authorized access only! ” (Đây là hệ thống được bảo mật, chỉ dành cho những người có thẩm quyền!) được sử dụng để cảnh báo những vị khách viếng thăm bất hợp pháp.

5. Cấu hình thông điệp đăng nhập (MOTD)

Thông điệp MOTD có thể hiển thị trên tất vả các thiết bị đầu cuối kết nối vào router.

Để cấu hình thông điệp MOTD bạn vào chế độ cấu hình toàn cục. Tại đây bạn dùng lệnh banner motd, cách một khoảng trắng, nhập ký tự phân cách ví dụ như ký tự #, rồi viết câu thông báo, kết thúc bằng cách nhập ký tự phân cách một lần nữa.

Vào chế độ cấu hình toàn cục bằng lệnh configure terminal

Nhập lệnh như sau: banner motd # The message of the day goes here #.

Lưu cấu hình vừa rồi bằng lệnh copy running-config startup-config.

6. Phân giải tên máy

Phân giải tên máy là quá trình máy tính phân giải từ tên mày thành địa chỉ IP tương ứng.

Để có thể liên hệ với các thiết bị IP khác bằng tên thì các thiết bị mạng như router cũng cần phải có khả năng phân giải tên máy thành địa chỉ IP. Danh sách giữa tên máy và điạ chỉ IP tương ứng được gọi là bảng host.

Bảng host có thể bao gồm tất cả các thiết bị mạng trong tổ chức của mình. Mỗi một địa chỉ IP có một tên máy tương ứng. Phần mềm Cisco IOS có một vùng đệm để lưu tên máy và địa chỉ tương ứng. Vùng bộ đệm này giúp cho quá trình phân giải tên thành địa chỉ được nhanh hơn.

Tuy nhiên tên máy ở đây không giống như tên DNS, nó chỉ có ý nghĩa đối với router mà nó được cấu hình mà thôi. Người quản trị mạng có thể cấu hình bảng host trên router với bất kỳ tên nào với IP nào và các thông tin này chỉ có ý nghĩa đối với router đó mà thôi.

The following is an exemple of the configuration of a host table on a router: Router(config)#ip host Auckland 172.16.32.1 Router(config)#ip host Beirut 192.168.53.1 Router(config)#ip host Capetown 192.168.89.1 Router(config)#ip host Denver 10.202.8.1

7. Cấu hình bảng host

Để khai báo tên cho các địa chỉ IP, đầu tiên bạn vào chế độ cấu hình toàn cục. Tại đây dùng lệnh ip host, theo sau là tên của thiết bị và tất cả các IP của nó. Như vậy tên máy này sẽ ánh xạ với từng địa chỉ IP của các cổng trên thiết bị đó. Khi đó bạn có thể dùng lệnh ping hay telnet tới thiết bị đó bằng tên của thiết bị hay địa chỉ IP tương ứng đều được.

Sau đay là các bước thực hiện cấu bảng host:

Vào chế độ cấu hình toàn cục của router.

Nhập lệnh ip host theo sau là tên của router và tất cả các địa chỉ IP của các cổng trên router đó.

Tiếp tục nhập tên và địa chỉ IP tương ứng của các router khác trong mạng

Lưu cấu hình vào NVRAM.

8. Lập hồ sơ và lưu dự phòng tập tin cấu hình

Tập tin cấu hình của các thiết bị mạng sẽ quyết định sự hoạt động của hệ thống. Công việc quản lý tập tin cấu hình của các thiết bị bao gồm các công việc sau:

Lập danh sách và so sánh với tập tin cấu hình trên các thiết bị đang hoạt động.

Lưu dự phòng các tập tin cấu hình lênh server mạng.

Thực hiện cài đặt và nâng cấp các phần mềm.

Chúng ta cần lưu dự phòng các tập tin cấu hình để sử dụng trong trường hợp có sự cố. Tập tin cấu hình có thể được lưu trên server mạng, ví dụ như TFTP server, hoặc là lưu trên đĩa và cất ở nơi an toàn. Ngoài ra chúng ta cũng nên lập hồ sơ đi kèm với các tập tin này.

9. Cắt, dán và chỉnh sửa tập tin cấu hình

Bước 1: nhập lệnh copy running-config tftp.

Bước 2: nhập địa chỉ IP của máy mà chúng ta sẽ lưu tập tin cấu hình lên đó.

Bước 3: nhập tên tập tin.

Bước 4: xác nhận lại câu lệnh bằng cách trả lời “yes“

Chúng ta có thể sử dụng tập tin cấu hình lưu trên server mạng để cấu hình cho router.

Để thực hiện điều này bạn làm theo các bước sau:

Nhập lênh copy tftp running-config.

Ở dấu nhắc tiếp theo bạn chọn loại tập tin cấu hình máy hay tập tin cấu hình mạng. Tập tin cấu hình mạng có chứa các lệnh có thể thực thi cho tất cả các router và server trong mạng. Còn loại tập tin cấu hình máy thì chỉnhcác lệnh thực thi cho một router mà thôi. Ở dấu nhắc kế tiếp, bạn nhập địa chỉ IP của máy nào mà bạn đang lưu tập tin cấu hình trên đó.

Sau đó nhập tên của tập tin hoặc là chấp nhận lấy tên mặc định. Tên của tập tin theo quy tắc của UNIX. Tên mặc định cho loại tập tin cấu hình máy là hostname-config, còn tên mặc định cho loại tập tin cấu hình mạng là netword-config. Trong môi trường DOS thì tên tập tin bị giới hạn với 8 ký tự và 3 ký tự mở rộng (ví dụ như: router.cfg). Cuối cùng bạn xác nhận lại tất cả các thông tin vừa rồi. Bạn lưu ý trên hình thì sẽ thấy là dấu nhắc chuyển ngay sang tên HocMangMayTinh. Điều này chứng tỏ là router được cấu hình lại ngay sau khi tập tin cấu hình vừa được tải xuống.

Tập tin cấu hình trên router cũng có thể được lưu vào đĩa bằng cách sao chép dưới dạng văn bản rồi lưu vào đĩa mềm hoặc đĩa cứng. Khi nào cần chép trở lại rouer thì bạn dùng chức năng soạn thảo cơ bản của chương trình mô phỏng thiết bị đầu cuối để cắt dán các dòng lệnh vào router.

Bài 8: Cấu Hình Router Cisco Cơ Bản / 2023

1. Các thành phần của Router

CPU — bộ xử lý trung tâm, các bạn chỉ cần hiểu nó giống như CPU của máy tính.

ROM — chứa chương trình kiểm tra khởi động (POST), Bootstrap (giống BIOS của máy tính) và Mini-IOS (recovery password, upgrade IOS). Nhiệm vụ chính của ROM là kiểm tra phần cứng khi khởi động, sau đó chép HĐH Cisco IOS từ flash vào RAM. Nội dung trong bộ nhớ ROM thì không thể xóa được.

RAM/DRAM — lưu trữ routing table, ARP cache, fast-switching cache, packet buffering (shared RAM), và packet hold queues (một số thuật ngữ đi vào các bài học sau các bạn sẽ hiểu từ từ); Đa số HĐH Cisco IOS chạy trên RAM; RAM còn lưu trữ file cấu hình đang chạy của router (running-config). Nội dung RAM bị mất khi tắt nguồn hoặc restart router.

FLASH — lưu toàn bộ HĐH Cisco IOS; giống với Harddisk trên máy tính.

NVRAM — non-volatile RAM lưu trữ file cấu hình backup/startup của router (startup-config); nội dung của NVRAM vẫn được giữ khi tắt nguồn hoặc restart router.

Interfaces — còn gọi là cổng, được kết nối trên board mạch chủ hoặc trên interface modules riêng biệt, qua đó những packet đi vào và đi ra router. Cổng Console sử dụng cáp rollover, dùng để cấu hình trực tiếp cho router. Cổng AUX giống với cổng console, nhưng sử dụng kết nối dial-up tới modem, hỗ trợ việc cấu hình từ xa. Còn lại là các cổng kết nối mạng thông thường: Gigabit, Fast Ethernet, Serial, …

2. Kết nối cấu hình qua cổng console

Hình trên là cáp rollover có một đầu là đầu RJ-45 (giống đầu cáp mạng thông thường của chúng ta), đầu còn lại là DB-9, cắm vào cổng COM trên máy tính.

Thông thường, trong môi trường thiết bị thực, để bắt đầu cấu hình cho router, ta phải kết nối bằng cáp rollover từ cổng COM trên máy tính đến cổng console trên router.

Sau đó, sử dụng phần mềm Hyper Terminal để kết nối đến router và bắt đầu cấu hình thông qua giao diện dòng lệnh (command line).

Do chúng ta đang học Lab ảo, nên chút nữa mình sẽ hướng dẫn kết nối cấu hình trên Packet Tracer.

3. Các chế độ cấu hình Router Cisco

Có 3 chế độ cấu hình cơ bản:

Priviledged EXEC Mode — bắt đầu bằng dấu “

#

”, cho phép toàn bộ câu lệnh hiển thị, một số cấu hình cơ bản (clock, copy, erase, …).

Global Configuration Mode — bắt đầu bằng “

(config)#

”, cho phép toàn bộ câu lệnh cấu hình lên router. Bên trong mode này, sẽ có các mode con cho từng loại cấu hình riêng biệt (xem hình vẽ).

– Chế độ User sẽ giới hạn các câu lệnh mà người dùng có thể thực thi được. Đối với chế độ cấu hình này người dùng chỉ có khả năng hiển thị các thông số cấu hình trên router. Không thể cấu hình để thay đổi các thông số cấu hình và hoạt động của router.

– Chế độ Privileged (cũng được gọi là chế độ EXEC).

Router#

– Chế độ Global Configuration.

Router# config terminal Router(config)#

– Chế độ cấu hình Interface, sub interface.

Router(config)# int fa0/0 Router(config-if)#  Router(config-subif)#

– Chế độ cấu hình line.

Router(config-line)#

Để thoát khỏi một mode, dùng câu lệnh “exit”. Để trở về Priviledged EXEC Mode, đứng ở phía trong, dùng câu lệnh “end” hoặc tổ hợp phím “Ctrl + Z”.

4. Các cấu hình router cơ bản

4.1 Đặt tên cho Router

Mỗi thiết bị router cần có 1 cái tên định danh nhằm kiểm soát và quản lý hiệu quả. Sau khi đặt tên “hostname” cho Router, thì giá trị hostname sẽ thay đổi lập tức.

Cấu trúc lệnh

Router(config)# hostname {tên muốn đặt}

Ví dụ:

Router(config)# hostname Router Router(config)# hostname HCM HCM (config)#

4.2 Cấu hình chống trôi dòng lệnh

Khi bạn đang cấu hình thiết bị, các log phun ra màn hình terminal từ các sự kiện sẽ bị dính vào các câu lệnh đang gõ của chúng ta. Điều này cực kì khó chịu, chính vì vậy câu lệnh “logging synchronous” sẽ giúp điều gì? “logging synchronous” sẽ hỗ trợ chúng ta nhảy dòng giữ nguyên dòng config đang gõ nếu có sự kiện log nào bắn ra màn hình terminal.

Router(config)# line console 0 Chuyển cấu hình vào chế độ line. Router(config-line)# logging synchronous

Muốn tắt chức năng chống trôi dòng lệnh Router Cisco thì như sau.

Router(config)# no logging console

4.3 Cấu hình mật khẩu

Chúng ta có thể chèn thêm 1 tầng bảo mật nữa cho router bằng cách thiết lập mật khẩu ở enable mode. Khi user muốn truy cập vào enable mode để có thể thay đổi hoặc cấu hình cho router thì buộc phải nhập mật khẩu này. Chúng ta có thể cấu hình mật khẩu cho enable mode bằng lệnh:

Router(config)# enable password cisco

Chúng ta có thể cấu hình mã hóa mật khẩu ở enable mode bằng thuật toán MD5 để đảm bảo an toàn cho router bằng lệnh enable secret:

Router(config)# enable secret cisco

Lưu ý: Bạn có thể cấu hình mã hóa tất cả mật khẩu trên router cùng 1 lúc bằng lệnh “#service password-encryption” ở global config mode. Tuy nhiên, lệnh này chỉ mã hóa mật khẩu ở dạng 7. Ở bài viết này chúng ta sẽ không đi sâu vào nội dung mật khẩu của Router Cisco.

Tiếp đến là cấu hình mật khẩu đối với port console của Router. Khi mà có ai đó hoặc quản trị viên cắm dây console trực tiếp vào port thì sẽ gặp prompt chứng thực mật khẩu để vào quản trị.

Router(config)# line console 0 Router(config-line)# password matkhaudacbiet

Vào chế độ line vty để cấu hình mật khẩu để cho phép telnet các cổng vty.

Router(config)# line vty 0 4 Router(config-line)# password matkhautelnet

Vào chế độ line auxiliary để cấu hình mật khẩu cổng aux.

Router(config)# line aux 0 Router(config-line)# password cisco

4.4 Tạo Login Banner/Motd Banner

Đặt lời chào khi người dùng đăng nhập qua cổng Console hay telnet vào Router. Trong thực tế lệnh “Banner” thường được dùng để ra các cảnh báo đối với các truy cập trái phép vào Router. Lệnh này chỉ có tính chất cung cấp thông tin về hệ thống mà người dùng đang truy cập vào.

Router(config)# banner motd “This is banner motd“ Router(config)# banner login “This is banner login “

Chú ý: LOGIN banner sẽ được hiển thị trước dấu nhắc nhập username và password. Sử dụng câu lệnh “#no banner login” để disable login banner. MOTD banner sẽ hiển thị trước login banner.

4.5 Show thông tin tên các Interface của Router

Khi bạn cấu hình router, quan trọng nhất là xác định xem có bao nhiêu cổng mạng trên Router và trạng thái hoạt động up/down của interface.

Router# show ip interface brief Interface IP-Address OK? Method Status Protocol FastEthernet0/0 unassigned YES unset up up FastEthernet0/1 unassigned YES unset administratively down down Serial1/0 unassigned YES unset administratively down down Serial1/1 unassigned YES unset administratively down down Serial1/2 unassigned YES unset administratively down down Serial1/3 unassigned YES unset administratively down down

4.6 Di chuyển giữa các Interface

Bạn sẽ thực hiện việc di chuyển chế độ cấu hình vào chế độ cấu hình các interface theo cú pháp lệnh như sau.

Lưu ý: + Đứng ở chế độ “Global Configuration Mode” để thực hiện việc di chuyển.

– Chuyển vào chế độ Serial Interface Configuration (Serial1/0) và thoát ra

Router(config)# int s1/0 Router(config-if)# exit Router(config)#

– Bạn cũng có thể di chuyển sang chế độ cấu hình của Interface Fast Ethernet 0/0 từ chế độ cấu hình của một Interface khác.

Router(config-if)# interface fa0/0

4.7 Cấu hình IP cổng Interface

Ở phần này bạn sẽ thực hiện việc cấu hình địa chỉ IP cho 1 cổng interface trên Router.

Cú pháp lệnh

# interface {số hiệu interface} # description {miêu tả} # ip address {ip-address} {subnet-mask} # no shutdown

– Chuyển vào chế độ cấu hình của Interface Fast Ethernet 0/0.

Router(config)# interface Fastethernet 0/0

– Cấu hình phần mô tả của cổng interface (tuỳ chọn thêm, nhưng khuyến khích).

Router(config-if)# description connect to Accounting LAN

– Cấu hình địa chỉ IP và Subnetmask phù hợp.

Router(config-if)# ip address 192.168.20.1 255.255.255.0

– Kích hoạt interface hoạt động. Nếu không có option này thì cổng interface vẫn sẽ ở trạng thái tắt (down).

Router(config-if)# no shutdown

4.8 Cấu hình Clock time Zone

Cấu hình vùng thời gian sẽ được hiển thị.

Router# show clock *00:32:55.043 UTC Fri Jul 28 2017 Router# config t Router(config)# clock timezone EST -5 Router(config)# exit Router# show clock *19:33:06.803 EST Thu Jul 28 2017

4.9 Gán tên định danh hostname cho một địa chỉ IP

Gán một host name cho một địa chỉ IP. Sau khi câu lệnh đó đã được thực thi, bạn có thể sử dụng host name thay vì sử dụng địa chỉ IP khi bạn thực hiện telnet hoặc ping đến địa chỉ IP đó.

Router(config)#ip host site_hcm 192.168.20.2 Router(config)#exit Router#ping *Mar 1 00:35:33.659: %SYS-5-CONFIG_I: Configured from console by console Router#ping site_hcm Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 192.168.20.2, timeout is 2 seconds: !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 4/8/12 ms

Liệt kê thông tin ánh xạ hostname và ip.

Router#show host Default domain is not set Name/address lookup uses static mappings Codes: UN - unknown, EX - expired, OK - OK, ?? - revalidate temp - temporary, perm - permanent NA - Not Applicable None - Not defined Host Port Flags Age Type Address(es) site_hcm None (perm, OK) 0 IP 192.168.20.2

4.10 Cấu hình không phân giải hostname

Khi bạn thực hiện cấu hình/ping ip hay domain, mặc định Router đều cố gắng phân giải domain đó sang địa chỉ hoặc ngược lại. Điều này vô hình chung làm chậm quá trình cấu hình và gây khó chịu. Thường mình sẽ tắt tính năng này như sau.

Router(config)# no ip domain-lookup Router(config)#

Tắt tính năng tự động phân dải một câu lệnh nhập vào không đúng sang một host name.

4.11 Cấu hình thời gian timeout

Cấu hình thời gian để giới hạn màn hình console sẽ tự động log off sau một khoảng thời gian không hoạt động. Nếu bạn cấu hình cấu trúc tham số “0 0 = phút giây” thì đồng nghĩa với việc console sẽ không bao giờ bị log off.

Router(config)# line console 0 Router(config-line)# exec-timeout 0 0 Router(config-line)#

4.12 Lưu file cấu hình đang chạy

Khi bạn đã cấu hình ổn và muốn lưu lại nội dung cấu hình nãy giờ (đang chạy trên RAM) vào file startup-config để khi router khởi động lại thì sẽ load nội dung cấu hình mà ta mong muốn.

Router# copy running-config startup-config Destination filename [startup-config]? Building configuration... [OK]

4.13 Xoá file cấu hình khởi động

Giờ bạn không muốn lúc khởi động Router xài cấu hình cũ nữa thì chỉ cần xoá nội dung file cấu hình khởi động của router (startup-config).

Router# erase startup-config Erasing the nvram filesystem will remove all configuration files! Continue? [confirm] [OK] Erase of nvram: complete Router# reload

4.14 Các option lệnh khác

– Hiển thị các thông tin về phần cứng của một interface.

Router# show controllers serial 0/0/0

– Hiển thị thời gian đã được cấu hình trên router.

Router# show clock *00:02:55.983 UTC Fri Mar 1 2002 Router# show hosts Default domain is not set Name/address lookup uses static mappings Codes: UN - unknown, EX - expired, OK - OK, ?? - revalidate temp - temporary, perm - permanent NA - Not Applicable None - Not defined Host Port Flags Age Type Address(es)

– Hiển thị thông tin các user đang kết nối trực tiếp vào thiết bị.

Router# show users

– Hiển thị lịch sử các câu lệnh đã thực thi trên router đang lưu trong bộ đệm history.

Router# show history config y terminal enable config terminal show clock show version show history

– Hiển thị thông tin về bộ nhớ Flash của Router.

Router# show flash

– Hiển thị các thông tin về IOS của Router.

Router# show version Cisco IOS Software, 2600 Software (C2691-ADVENTERPRISEK9-M), Version 12.4(15)T14, RELEASE SOFTWARE (fc2) Technical Support: http://www.cisco.com/techsupport Copyright (c) 1986-2010 by Cisco Systems, Inc. Compiled Tue 17-Aug-10 07:38 by prod_rel_team ROM: ROMMON Emulation Microcode ROM: 2600 Software (C2691-ADVENTERPRISEK9-M), Version 12.4(15)T14, RELEASE SOFTWARE (fc2) Router uptime is 1 minute System returned to ROM by unknown reload cause - suspect boot_data[BOOT_COUNT] 0x0, BOOT_COUNT 0, BOOTDATA 19 System image file is "tftp://255.255.255.255/unknown" ....

– Hiển thị bảng thông tin ARP trên router.

Router# show arp Protocol Address Age (min) Hardware Addr Type Interface Internet 192.168.20.1 0 c001.068d.0000 ARPA FastEthernet0/0 Internet 192.168.20.2 - c002.06cf.0000 ARPA FastEthernet0/0

– Xem nội dung cấu hình đang chạy trên RAM.

Router# show running-config

– Kiểm tra nội dung file cấu hình đã lưu ở NVRAM.

Router# show startup-config

5. Lab cấu hình Router Cisco cơ bản

Mô hình:

Link Youtube: Tại đây

Link file hướng dẫn lab: Tại đây

Bạn đang đọc nội dung bài viết Cấu Hình Switch Port, Vlans, Trunk, Vtp, Intervlan Routing / 2023 trên website Welovelevis.com. Hy vọng một phần nào đó những thông tin mà chúng tôi đã cung cấp là rất hữu ích với bạn. Nếu nội dung bài viết hay, ý nghĩa bạn hãy chia sẻ với bạn bè của mình và luôn theo dõi, ủng hộ chúng tôi để cập nhật những thông tin mới nhất. Chúc bạn một ngày tốt lành!