Đề Xuất 12/2022 # Thiết Lập Cấu Hình Dòng Switch 2960, 2960X, 2960S Chuẩn Layer 2, Hướng Dẫn 7 Bước Thiết Lập Cấu Hình Switch Cisco 2960 Nói Chung / 2023 # Top 16 Like | Welovelevis.com

Đề Xuất 12/2022 # Thiết Lập Cấu Hình Dòng Switch 2960, 2960X, 2960S Chuẩn Layer 2, Hướng Dẫn 7 Bước Thiết Lập Cấu Hình Switch Cisco 2960 Nói Chung / 2023 # Top 16 Like

Cập nhật nội dung chi tiết về Thiết Lập Cấu Hình Dòng Switch 2960, 2960X, 2960S Chuẩn Layer 2, Hướng Dẫn 7 Bước Thiết Lập Cấu Hình Switch Cisco 2960 Nói Chung / 2023 mới nhất trên website Welovelevis.com. Hy vọng thông tin trong bài viết sẽ đáp ứng được nhu cầu ngoài mong đợi của bạn, chúng tôi sẽ làm việc thường xuyên để cập nhật nội dung mới nhằm giúp bạn nhận được thông tin nhanh chóng và chính xác nhất.

Hướng dẫn cấu hình căn bản dành cho switch cisco 2960, khách hàng có thể tham khảo và thao tác cấu hình thử. Bài viết dành cho các quản trị mạng server đã có kiến thức cơ bản về hạ tầng hệ thống mạng doanh nghiệp

Bài hướng dẫn cấu hình này sẽ mô tả cách cấu hình các thông số cơ bản cho thiết bị Switch Cisco Catalyst 2960 bao gồm: cài đặt tên, cài đặt IP và password

Các bước tiến hành thực hiện:

Bước 1: Kết nối cổng COM của laptop hoặc pc với cổng Console của Switch 2960 (cổng này được bố trí ở mặt sau của thiết bị) sử dụng cáp Rolled – Over. Các thông số để quy cập: 8 data bit, no parity, 1 stop bit, no flow control

Bước 2: Kết nối nguồn và bật switch sau đó theo dõi quá trình khởi động (khoảng 1 phút)

C2900XL Boot Loader (C2900-HBOOT-M) Version 12.0(5)XU, RELEASE

SOFTWARE (fc1) Compiled Mon 03-Apr-00 17:20 by starting... Base ethernet MAC Address: 00:02:b9:9a:85:80 Xmodem file system is available. flashfs[0]: 108 files, 3 directories flashfs[0]: 0 orphaned files, 0 orphaned directories flashfs[0]: Total bytes: 3612672 flashfs[0]: Bytes used: 2775040 flashfs[0]: Bytes available: 837632 flashfs[0]: flashfs fsck took 6 seconds. chúng tôi Initializing Flash. Boot Sector Filesystem (bs installed, fsid: 3 Parameter Block Filesystem (pb installed, fsid: 4 Loading flash:c2900XL-c3h2s-mz-120.5-

Bước 3: Khi thiết bị đã khởi động xong bạn sẽ nhận được thông báo bằng System Configuration Dialog (vì cấu hình switch hoàn toàn mới)

Giống với router, bạn cần ấn No để quá trình không chạy vào phần Setup Mode mà chuyển trực tiếp sang User Exec Mode:

Bước 4: Nhấn enable để truy cập vào privileged mode

Switch#show running-config

Building configuration...

Current configuration: ! version 12.0 no service pad service timestamps debug uptime service timestamps log uptime no service mật khẩu-encryption ! hostname Switch ! ip subnet-zero ! interface FastEthernet0/1 ! interface FastEthernet0/2 ! interface FastEthernet0/3 !

–More—

! interface VLAN1 no ip directed-broadcast no ip route-cache ! line con 0 transport input none stopbits 1 line vty 5 15 ! end

Như các thông số hiển thị bên trên, cấu hình của switch sẽ rất giống trên router, các interface trên switch là các port của switch.

Bước 5: Tếp theo, ta tiến hành đặt tên cho switch và đặt các mật khẩu truy cập

Đặt tên cho thiết bị

Switch#config terminal

Switch(config)#host ALSwitch

ALSwitch(config)#

Đặt mật khẩu

ALSwitch(config)#enable password class

ALSwitch(config)#line con 0

ALSwitch(config-line)#password cisco

ALSwitch(config-line)#login

ALSwitch(config-line)#line vty 0 15

ALSwitch(config-line)#password cisco

ALSwitch(config-line)#login

Dùng câu lệnh copy để lưu cấu hình từ RAM vào NVRAM:

ALSwitch#copy running-config startup-config

Bước 6: Tiến hành đặt địa chỉ IP cho switch để nó có thể liên lạc với các thiết bị khác qua trên mạng. Switch là một thiết bị lớp 2. Việc đặt IP address cho switch chỉ nhằm mục đích quản trị.

Tất cả các port mặt định của VLAN 1, do đó phải cấu hình cho quản lý switch dùng VLAN 1. Bạn cấu hình VLAN 1 như cấu hình một cổng giao tiếp của router khi gán địa chỉ IP.

ALSwitch#config terminal

ALSwitch(config)#interface vlan 1

ALSwitch(config-if)#ip address 10.1.1.251 255.255.255.0

Vì switch không thể cấu hình giao thức định tuyến, nên để tới tất cả các mạng, ta phải cấu hình một địa chỉ gateway mặc định để gởi tất cả lưu lượng khi ta cần liên lạc giữa các VLAN.

ALSwitch(config)#ip default-gateway 10.1.1.1

Bước 7: Cấu hình PC của bạn cho nó là một thành phần trong mạng 10.1.1.0/24 (giả sử đặt địa chỉ IP cho PC là 10.1.1.10/24). Cắm PC vào một port bất kỳ của switch.

Từ PC Telnet vào switch dùng địa chỉ đã cấu hình 10.1.1.251 (Từ Window: Start/Run/Telnet 10.1.1.251)

Sau khi đã telnet thành công, thử một số lệnh trên switch:

ALSwitch#show interfaces

FastEthernet0/1 is down, line protocol is down

Hardware is Fast Ethernet, address is 0002.fd49.7b81 (bia

0002.fd49.7b81)

MTU 1500 bytes, BW 0 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive not set

Auto-duplex , Auto Speed , 100BaseTX/FX

ARP type: ARPA, ARP Timeout 04:00:00

Last input never, output never, output hang never

Last clearing of "show interface" counters never

–More—

Lệnh show version để xem thông tin phần cứng và phần mềm

ALSwitch#show version

Cisco Internetwork Operating System Software IOS (tm) C2900XL Software (C2900XL-C3H2S-M), Version 12.0(5)XU, RELEASE SOFTWARE Compiled Mon 03-Apr-00 16:37 by swati Image text-base: 0x00003000, data-base: 0x00301398 ROM: Bootstrap program is C2900XL boot loader ALSwitch uptime is 16 minutes System returned to ROM by power-on System image file is flash:c2900XL-c3h2s-mz-120.5-XU.bin cisco WS-C2924-XL (PowerPC403GA) processor (revision 0x11) with 8192K/1024K bytes of memory. . . . . 24 FastEthernet/IEEE 802.3 interface(s) 32K bytes of flash-simulated non-volatile configuration memory. Base ethernet MAC Address: 00:02:FD:49:7B:80 Motherboard assembly number: 73-3382-08 Power supply part number: 34-0834-01 Motherboard serial number: FAB04301ANJ Power supply serial number: PHI04150042 Model revision number: A0 Motherboard revision number: B0 Model number: WS-C2924-XL-EN System serial number: FAB0432S2GJ Configuration register is 0xF ALSwitch#

Cấu Hình Switch Port, Vlans, Trunk, Vtp, Intervlan Routing / 2023

Yêu cầu:

Cấu hình trung kế:

Cấu hình trung kế Dot1q kết nối giữa Switch – Switch.

Cấu hình trung kế Dot1q kết nối giữa Switch – Router.

Cấu hình VTP:

Mỗi nhóm cấu hình VTP theo các yêu cầu sau:

VTP domain: BCMSNx (x là số thứ tự của nhóm, x = 1,2,3).

VTP pass: CISCO (lưu ý chữ hoa chữ thường).

SWx1 là VTP server.

SWx2, SWx3 là VTP client.

Cấu hình VLANs:

Mỗi nhóm tạo 3 VLANs tương ứng với mô hình trên

Ví dụ: nhóm 1 tạo VLAN11, VLAN12, VLAN13.

Gán port vào VLAN như sau:

x là số thứ tự của nhóm (x = 1,2,3).

Cấu hình định tuyến giữa các VLAN:

Mỗi nhóm cấu hình để 3 VLAN trong mỗi nhóm có thể ping thấy nhau.

Mỗi nhóm cấu hình giao thức định tuyến OSPF để tất cả VLAN và Interface Loopback có thể ping thấy nhau.

  Gợi ý:

2a: Dùng lệnh sau trên switch trong mode interface:

Switch(config-if)# switchport trunk encapsulation dot1q

Switch(config-if)# switchport mode trunk

!Lưu ý: phải gõ lệnh “switchport trunk encapsulation dot1q” trước lệnh “switchport mode trunk”, nếu gõ theo thứ tự ngược lại sẽ không thể tạo kết nối trung kế thành công

2b: Dùng lệnh sau trên router để cấu hình trung kế dot1q:

Router(config)# interface fastethernet 0/0.11

Router(config-if)# encapsulation dot1q 10

Router(config-if)# ip address 192.168.1.1 255.255.255.0

!lưu ý: câu lệnh trên tạo subinterface f0/0.11, chỉ định encapsulation là dot1q, thuộc VLAN 10 và có IP 192.168.1.1.

3: Dùng lệnh sau để cấu hình VTP:

Switch(config)# vtp domain BCMSN

Switch(config)# vtp password CISCO

4: Dùng các lệnh sau để cấu hình VLAN:

Switch(config)# vlan 10

Switch(config-vlan)# name VLAN10                       !ßđặt tên là VLAN10

Switch(config)# interface range fastethernet 0/1 – 6

Switch(config-if-range)# switchport mode access

Switch(config-if-range)# switchport access vlan 10        

Cấu hình đầy đủ:

!Nhóm 1:

!SW11:

! configure terminal

! interface fastEthernet0/8

switchport trunk encapsulation dot1q

switchport mode trunk

! interface fastEthernet0/9

switchport trunk encapsulation dot1q

switchport mode trunk

! interface fastEthernet0/24

switchport trunk encapsulation dot1q

switchport mode trunk

! vtp domain BCMSN1

vtp pass CISCO

! vlan 11

name VLAN11

! vlan 12

name VLAN12

! vlan 13

name VLAN13

! interface range fastEthernet0/1 – 7

switchport mode access

switchport access vlan 11

! interface range fastEthernet0/10 – 16

switchport mode access

switchport access vlan 12

! int range fastEthernet0/17 – 23

switchport mode access

switchport access vlan 13

! end

!SW12:

! configure terminal

! interface fastEthernet0/8

switchport trunk encapsulation dot1q

switchport mode trunk

! vtp mode client

vtp domain BCMSN1

vtp pass CISCO

! interface range fastEthernet0/1 – 7

switchport mode access

switchport access vlan 11

! interface range fastEthernet0/9 – 16

switchport mode access

switchport access vlan 12

! interface range fastEthernet0/17 – 24

switchport mode access

switchport access vlan 13

! end

SW13:

configure terminal

! interface fastEthernet0/8

switchport trunk encapsulation dot1q

switchport mode trunk

! vtp mode client

vtp domain BCMSN1

vtp pass CISCO

! interface range fastEthernet0/1 – 7

switchport mode access

switchport access vlan 11

! interface range fastEthernet0/10 – 16

switchport mode access

switchport access vlan 12

! interface range fastEthernet0/17 – 24

switchport mode access

switchport access vlan 13

! end

!R11:

configure terminal

! interface loopback0

ip address 1.1.1.1 255.255.255.0

! interface serial0/0

clock rate 64000

ip address 192.168.1.1 255.255.255.0

no shutdown

! interface fastEthernet0/0

no shutdown

! interface fastEthernet0/0.11

encapsulation dot1q 11

ip address 172.16.1.1 255.255.255.0

! interface fastEthernet0/0.12

encapsulation dot1q 12

ip address 172.16.2.1 255.255.255.0

! interface fastEthernet0/0.13

encapsulation dot1q 13

ip address 172.16.3.1 255.255.255.0

! router ospf 1

network 0.0.0.0 255.255.255.255 are 0

! end      

!Nhóm 2:

SW21:

! configure terminal

! interface fastEthernet0/8

switchport trunk encapsulation dot1q

switchport mode trunk

! interface fastEthernet0/9

switchport trunk encapsulation dot1q

switchport mode trunk

! interface fastEthernet0/24

switchport trunk encapsulation dot1q

switchport mode trunk

! vtp domain BCMSN2

vtp pass CISCO

! vlan 21

name VLAN21

! vlan 22

name VLAN22

! vlan 23

name VLAN23

! interface range fastEthernet0/1 – 7

switchport mode access

switchport access vlan 21

! interface range fastEthernet0/10 – 16

switchport mode access

switchport access vlan 22

! interface range fastEthernet0/17 – 23

switchport mode access

switchport access vlan 23

! end  

SW22:

! configure terminal

! interface fastEthernet0/8

switchport trunk encapsulation dot1q

switchport mode trunk

! vtp domain BCMSN2

vtp mode client

vtp pass CISCO

! interface range fastEthernet0/1 – 7

switchport mode access

switchport access vlan 21

! interface range fastEthernet0/9 – 16

switchport mode access

switchport access vlan 22

! interface range fastEthernet0/17 – 24

switchport mode access

switchport access vlan 23

! end  

SW23:

! configure terminal

! interface fastEthernet0/8

switchport trunk encapsulation dot1q

switchport mode trunk

! vtp domain BCMSN2

vtp mode client

vtp pass CISCO

! interface range fastEthernet0/1 – 7

switchport mode access

switchport access vlan 21

! interface range fastEthernet0/9 – 16

switchport mode access

switchport access vlan 22

! interface range fastEthernet0/17 – 24

switchport mode access

switchport access vlan 23

! end  

R21:

! configure terminal

! interface loopback0

ip address 2.2.2.2 255.255.255.0

! interface serial0/0

clock rate 64000

ip address 192.168.1.2 255.255.255.0

no shutdown

! interface serial0/1

clock rate 64000

ip address 192.168.2.2 255.255.255.0

no shutdown

! interface fastEthernet0/0

no shutdown

! interface fastEthernet0/0.21

encapsulation dot1q 21

ip address 172.17.1.1 255.255.255.0

! interface fastEthernet0/0.22

encapsulation dot1q 22

ip address 172.17.2.1 255.255.255.0

! interface fastEthernet0/0.23

encapsulation dot1q 23

ip address 172.17.3.1 255.255.255.0

! router ospf 1

network 0.0.0.0 255.255.255.255 are 0

! end      

!Nhóm 3:

SW31:

! configure terminal

! interface fastEthernet0/8

switchport trunk encapsulation dot1q

switchport mode trunk

! interface fastEthernet0/9

switchport trunk encapsulation dot1q

switchport mode trunk

! interface fastEthernet0/24

switchport trunk encapsulation dot1q

switchport mode trunk

! vtp domain BCMSN3

vtp pass CISCO

! vlan 31

name VLAN31

! vlan 32

name VLAN32

! vlan 33

name VLAN33

! interface range fastEthernet0/1 – 7

switchport mode access

switchport access vlan 31

! interface range fastEthernet0/10 – 16

switchport mode access

switchport access vlan 32

! interface range fastEthernet0/17 – 23

switchport mode access

switchport access vlan 33

! end  

SW32:

! configure terminal

! interface fastEthernet0/8

switchport trunk encapsulation dot1q

switchport mode trunk

! vtp mode client

vtp domain BCMSN3

vtp pass CISCO

! interface range fastEthernet0/1 – 7

switchport mode access

switchport access vlan 31

! interface range fastEthernet0/9 – 16

switchport mode access

switchport access vlan 32

! interface range fastEthernet0/17 – 24

switchport mode access

switchport access vlan 33

! end    

SW33:

! configure terminal

! interface fastEthernet0/8

switchport trunk encapsulation dot1q

switchport mode trunk

! vtp mode client

vtp domain BCMSN3

vtp pass

CISCO

! interface range fastEthernet0/1 – 7

switchport mode access

switchport access vlan 31

! interface range fastEthernet0/9 – 16

switchport mode access

switchport access vlan 32

! interface range fastEthernet0/17 – 24

switchport mode access

switchport access vlan 33

! end

R31:

configure terminal

! interface loop 0

ip address 3.3.3.3 255.255.255.0

! interface s0/0

clock rate 64000

ip address 192.168.2.3 255.255.255.0

no shutdown

! interface fastEthernet0/0

no shutdown

! interface fastEthernet0/0.31

encapsulation dot1q 31

ip address 172.18.1.1 255.255.255.0

! interface fastEthernet0/0.32

encapsulation dot1q 32

ip address 172.18.2.1 255.255.255.0

! interface fastEthernet0/0.33

encapsulation dot1q 33

ip address 172.18.3.1 255.255.255.0

! router ospf 1

network 0.0.0.0 255.255.255.255 are 0 !

end      

!kiem tra trunk

#show int trunk  

!kiem tra vtp

#show vtp status

 !kiem tra routing table

#show ip route

Bài 8: Cấu Hình Router Cisco Cơ Bản / 2023

1. Các thành phần của Router

CPU — bộ xử lý trung tâm, các bạn chỉ cần hiểu nó giống như CPU của máy tính.

ROM — chứa chương trình kiểm tra khởi động (POST), Bootstrap (giống BIOS của máy tính) và Mini-IOS (recovery password, upgrade IOS). Nhiệm vụ chính của ROM là kiểm tra phần cứng khi khởi động, sau đó chép HĐH Cisco IOS từ flash vào RAM. Nội dung trong bộ nhớ ROM thì không thể xóa được.

RAM/DRAM — lưu trữ routing table, ARP cache, fast-switching cache, packet buffering (shared RAM), và packet hold queues (một số thuật ngữ đi vào các bài học sau các bạn sẽ hiểu từ từ); Đa số HĐH Cisco IOS chạy trên RAM; RAM còn lưu trữ file cấu hình đang chạy của router (running-config). Nội dung RAM bị mất khi tắt nguồn hoặc restart router.

FLASH — lưu toàn bộ HĐH Cisco IOS; giống với Harddisk trên máy tính.

NVRAM — non-volatile RAM lưu trữ file cấu hình backup/startup của router (startup-config); nội dung của NVRAM vẫn được giữ khi tắt nguồn hoặc restart router.

Interfaces — còn gọi là cổng, được kết nối trên board mạch chủ hoặc trên interface modules riêng biệt, qua đó những packet đi vào và đi ra router. Cổng Console sử dụng cáp rollover, dùng để cấu hình trực tiếp cho router. Cổng AUX giống với cổng console, nhưng sử dụng kết nối dial-up tới modem, hỗ trợ việc cấu hình từ xa. Còn lại là các cổng kết nối mạng thông thường: Gigabit, Fast Ethernet, Serial, …

2. Kết nối cấu hình qua cổng console

Hình trên là cáp rollover có một đầu là đầu RJ-45 (giống đầu cáp mạng thông thường của chúng ta), đầu còn lại là DB-9, cắm vào cổng COM trên máy tính.

Thông thường, trong môi trường thiết bị thực, để bắt đầu cấu hình cho router, ta phải kết nối bằng cáp rollover từ cổng COM trên máy tính đến cổng console trên router.

Sau đó, sử dụng phần mềm Hyper Terminal để kết nối đến router và bắt đầu cấu hình thông qua giao diện dòng lệnh (command line).

Do chúng ta đang học Lab ảo, nên chút nữa mình sẽ hướng dẫn kết nối cấu hình trên Packet Tracer.

3. Các chế độ cấu hình Router Cisco

Có 3 chế độ cấu hình cơ bản:

Priviledged EXEC Mode — bắt đầu bằng dấu “

#

”, cho phép toàn bộ câu lệnh hiển thị, một số cấu hình cơ bản (clock, copy, erase, …).

Global Configuration Mode — bắt đầu bằng “

(config)#

”, cho phép toàn bộ câu lệnh cấu hình lên router. Bên trong mode này, sẽ có các mode con cho từng loại cấu hình riêng biệt (xem hình vẽ).

– Chế độ User sẽ giới hạn các câu lệnh mà người dùng có thể thực thi được. Đối với chế độ cấu hình này người dùng chỉ có khả năng hiển thị các thông số cấu hình trên router. Không thể cấu hình để thay đổi các thông số cấu hình và hoạt động của router.

– Chế độ Privileged (cũng được gọi là chế độ EXEC).

Router#

– Chế độ Global Configuration.

Router# config terminal Router(config)#

– Chế độ cấu hình Interface, sub interface.

Router(config)# int fa0/0 Router(config-if)#  Router(config-subif)#

– Chế độ cấu hình line.

Router(config-line)#

Để thoát khỏi một mode, dùng câu lệnh “exit”. Để trở về Priviledged EXEC Mode, đứng ở phía trong, dùng câu lệnh “end” hoặc tổ hợp phím “Ctrl + Z”.

4. Các cấu hình router cơ bản

4.1 Đặt tên cho Router

Mỗi thiết bị router cần có 1 cái tên định danh nhằm kiểm soát và quản lý hiệu quả. Sau khi đặt tên “hostname” cho Router, thì giá trị hostname sẽ thay đổi lập tức.

Cấu trúc lệnh

Router(config)# hostname {tên muốn đặt}

Ví dụ:

Router(config)# hostname Router Router(config)# hostname HCM HCM (config)#

4.2 Cấu hình chống trôi dòng lệnh

Khi bạn đang cấu hình thiết bị, các log phun ra màn hình terminal từ các sự kiện sẽ bị dính vào các câu lệnh đang gõ của chúng ta. Điều này cực kì khó chịu, chính vì vậy câu lệnh “logging synchronous” sẽ giúp điều gì? “logging synchronous” sẽ hỗ trợ chúng ta nhảy dòng giữ nguyên dòng config đang gõ nếu có sự kiện log nào bắn ra màn hình terminal.

Router(config)# line console 0 Chuyển cấu hình vào chế độ line. Router(config-line)# logging synchronous

Muốn tắt chức năng chống trôi dòng lệnh Router Cisco thì như sau.

Router(config)# no logging console

4.3 Cấu hình mật khẩu

Chúng ta có thể chèn thêm 1 tầng bảo mật nữa cho router bằng cách thiết lập mật khẩu ở enable mode. Khi user muốn truy cập vào enable mode để có thể thay đổi hoặc cấu hình cho router thì buộc phải nhập mật khẩu này. Chúng ta có thể cấu hình mật khẩu cho enable mode bằng lệnh:

Router(config)# enable password cisco

Chúng ta có thể cấu hình mã hóa mật khẩu ở enable mode bằng thuật toán MD5 để đảm bảo an toàn cho router bằng lệnh enable secret:

Router(config)# enable secret cisco

Lưu ý: Bạn có thể cấu hình mã hóa tất cả mật khẩu trên router cùng 1 lúc bằng lệnh “#service password-encryption” ở global config mode. Tuy nhiên, lệnh này chỉ mã hóa mật khẩu ở dạng 7. Ở bài viết này chúng ta sẽ không đi sâu vào nội dung mật khẩu của Router Cisco.

Tiếp đến là cấu hình mật khẩu đối với port console của Router. Khi mà có ai đó hoặc quản trị viên cắm dây console trực tiếp vào port thì sẽ gặp prompt chứng thực mật khẩu để vào quản trị.

Router(config)# line console 0 Router(config-line)# password matkhaudacbiet

Vào chế độ line vty để cấu hình mật khẩu để cho phép telnet các cổng vty.

Router(config)# line vty 0 4 Router(config-line)# password matkhautelnet

Vào chế độ line auxiliary để cấu hình mật khẩu cổng aux.

Router(config)# line aux 0 Router(config-line)# password cisco

4.4 Tạo Login Banner/Motd Banner

Đặt lời chào khi người dùng đăng nhập qua cổng Console hay telnet vào Router. Trong thực tế lệnh “Banner” thường được dùng để ra các cảnh báo đối với các truy cập trái phép vào Router. Lệnh này chỉ có tính chất cung cấp thông tin về hệ thống mà người dùng đang truy cập vào.

Router(config)# banner motd “This is banner motd“ Router(config)# banner login “This is banner login “

Chú ý: LOGIN banner sẽ được hiển thị trước dấu nhắc nhập username và password. Sử dụng câu lệnh “#no banner login” để disable login banner. MOTD banner sẽ hiển thị trước login banner.

4.5 Show thông tin tên các Interface của Router

Khi bạn cấu hình router, quan trọng nhất là xác định xem có bao nhiêu cổng mạng trên Router và trạng thái hoạt động up/down của interface.

Router# show ip interface brief Interface IP-Address OK? Method Status Protocol FastEthernet0/0 unassigned YES unset up up FastEthernet0/1 unassigned YES unset administratively down down Serial1/0 unassigned YES unset administratively down down Serial1/1 unassigned YES unset administratively down down Serial1/2 unassigned YES unset administratively down down Serial1/3 unassigned YES unset administratively down down

4.6 Di chuyển giữa các Interface

Bạn sẽ thực hiện việc di chuyển chế độ cấu hình vào chế độ cấu hình các interface theo cú pháp lệnh như sau.

Lưu ý: + Đứng ở chế độ “Global Configuration Mode” để thực hiện việc di chuyển.

– Chuyển vào chế độ Serial Interface Configuration (Serial1/0) và thoát ra

Router(config)# int s1/0 Router(config-if)# exit Router(config)#

– Bạn cũng có thể di chuyển sang chế độ cấu hình của Interface Fast Ethernet 0/0 từ chế độ cấu hình của một Interface khác.

Router(config-if)# interface fa0/0

4.7 Cấu hình IP cổng Interface

Ở phần này bạn sẽ thực hiện việc cấu hình địa chỉ IP cho 1 cổng interface trên Router.

Cú pháp lệnh

# interface {số hiệu interface} # description {miêu tả} # ip address {ip-address} {subnet-mask} # no shutdown

– Chuyển vào chế độ cấu hình của Interface Fast Ethernet 0/0.

Router(config)# interface Fastethernet 0/0

– Cấu hình phần mô tả của cổng interface (tuỳ chọn thêm, nhưng khuyến khích).

Router(config-if)# description connect to Accounting LAN

– Cấu hình địa chỉ IP và Subnetmask phù hợp.

Router(config-if)# ip address 192.168.20.1 255.255.255.0

– Kích hoạt interface hoạt động. Nếu không có option này thì cổng interface vẫn sẽ ở trạng thái tắt (down).

Router(config-if)# no shutdown

4.8 Cấu hình Clock time Zone

Cấu hình vùng thời gian sẽ được hiển thị.

Router# show clock *00:32:55.043 UTC Fri Jul 28 2017 Router# config t Router(config)# clock timezone EST -5 Router(config)# exit Router# show clock *19:33:06.803 EST Thu Jul 28 2017

4.9 Gán tên định danh hostname cho một địa chỉ IP

Gán một host name cho một địa chỉ IP. Sau khi câu lệnh đó đã được thực thi, bạn có thể sử dụng host name thay vì sử dụng địa chỉ IP khi bạn thực hiện telnet hoặc ping đến địa chỉ IP đó.

Router(config)#ip host site_hcm 192.168.20.2 Router(config)#exit Router#ping *Mar 1 00:35:33.659: %SYS-5-CONFIG_I: Configured from console by console Router#ping site_hcm Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 192.168.20.2, timeout is 2 seconds: !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 4/8/12 ms

Liệt kê thông tin ánh xạ hostname và ip.

Router#show host Default domain is not set Name/address lookup uses static mappings Codes: UN - unknown, EX - expired, OK - OK, ?? - revalidate temp - temporary, perm - permanent NA - Not Applicable None - Not defined Host Port Flags Age Type Address(es) site_hcm None (perm, OK) 0 IP 192.168.20.2

4.10 Cấu hình không phân giải hostname

Khi bạn thực hiện cấu hình/ping ip hay domain, mặc định Router đều cố gắng phân giải domain đó sang địa chỉ hoặc ngược lại. Điều này vô hình chung làm chậm quá trình cấu hình và gây khó chịu. Thường mình sẽ tắt tính năng này như sau.

Router(config)# no ip domain-lookup Router(config)#

Tắt tính năng tự động phân dải một câu lệnh nhập vào không đúng sang một host name.

4.11 Cấu hình thời gian timeout

Cấu hình thời gian để giới hạn màn hình console sẽ tự động log off sau một khoảng thời gian không hoạt động. Nếu bạn cấu hình cấu trúc tham số “0 0 = phút giây” thì đồng nghĩa với việc console sẽ không bao giờ bị log off.

Router(config)# line console 0 Router(config-line)# exec-timeout 0 0 Router(config-line)#

4.12 Lưu file cấu hình đang chạy

Khi bạn đã cấu hình ổn và muốn lưu lại nội dung cấu hình nãy giờ (đang chạy trên RAM) vào file startup-config để khi router khởi động lại thì sẽ load nội dung cấu hình mà ta mong muốn.

Router# copy running-config startup-config Destination filename [startup-config]? Building configuration... [OK]

4.13 Xoá file cấu hình khởi động

Giờ bạn không muốn lúc khởi động Router xài cấu hình cũ nữa thì chỉ cần xoá nội dung file cấu hình khởi động của router (startup-config).

Router# erase startup-config Erasing the nvram filesystem will remove all configuration files! Continue? [confirm] [OK] Erase of nvram: complete Router# reload

4.14 Các option lệnh khác

– Hiển thị các thông tin về phần cứng của một interface.

Router# show controllers serial 0/0/0

– Hiển thị thời gian đã được cấu hình trên router.

Router# show clock *00:02:55.983 UTC Fri Mar 1 2002 Router# show hosts Default domain is not set Name/address lookup uses static mappings Codes: UN - unknown, EX - expired, OK - OK, ?? - revalidate temp - temporary, perm - permanent NA - Not Applicable None - Not defined Host Port Flags Age Type Address(es)

– Hiển thị thông tin các user đang kết nối trực tiếp vào thiết bị.

Router# show users

– Hiển thị lịch sử các câu lệnh đã thực thi trên router đang lưu trong bộ đệm history.

Router# show history config y terminal enable config terminal show clock show version show history

– Hiển thị thông tin về bộ nhớ Flash của Router.

Router# show flash

– Hiển thị các thông tin về IOS của Router.

Router# show version Cisco IOS Software, 2600 Software (C2691-ADVENTERPRISEK9-M), Version 12.4(15)T14, RELEASE SOFTWARE (fc2) Technical Support: http://www.cisco.com/techsupport Copyright (c) 1986-2010 by Cisco Systems, Inc. Compiled Tue 17-Aug-10 07:38 by prod_rel_team ROM: ROMMON Emulation Microcode ROM: 2600 Software (C2691-ADVENTERPRISEK9-M), Version 12.4(15)T14, RELEASE SOFTWARE (fc2) Router uptime is 1 minute System returned to ROM by unknown reload cause - suspect boot_data[BOOT_COUNT] 0x0, BOOT_COUNT 0, BOOTDATA 19 System image file is "tftp://255.255.255.255/unknown" ....

– Hiển thị bảng thông tin ARP trên router.

Router# show arp Protocol Address Age (min) Hardware Addr Type Interface Internet 192.168.20.1 0 c001.068d.0000 ARPA FastEthernet0/0 Internet 192.168.20.2 - c002.06cf.0000 ARPA FastEthernet0/0

– Xem nội dung cấu hình đang chạy trên RAM.

Router# show running-config

– Kiểm tra nội dung file cấu hình đã lưu ở NVRAM.

Router# show startup-config

5. Lab cấu hình Router Cisco cơ bản

Mô hình:

Link Youtube: Tại đây

Link file hướng dẫn lab: Tại đây

Hướng Dẫn Cách Cài Đặt Cấu Hình Đầu Ghi Vantech Từ A Đến Z / 2023

Thương hiệu camera Vantech đã khẳng định được uy tín tại thị trường Việt Nam trong hơn các năm qua. Sản phẩm của Vantech chủ yếu là camera, đầu ghi hình kỹ thuật số và các phụ kiện khác như card ghi hình, bàn điều khiển, bộ chia hình, chân đế, … Công Nghệ Hoàng Danh có đủ đầy các dòng công nghệ, đa dạng về tính năng và đáp ứng được hầu hết nhu cầu của thị trường.

Có 2 bước cấu hình đầu ghi camera Vantech

Congnghehoangdanh xin lựa chọn đầu ghi Vantech VT8100E để huớng dẫn cài đặt trong bài viết này. Để cài đặt và cấu hình đầu ghi Vantech Model loại VT8100e bạn cần thực hiện 2 bước sau:

Bước 1: Cài đặt đầu ghi hình

Đầu tiên, bạn cài đặt phần mềm iDVRemoteDesktop trên máy tính và đăng nhập vào phần mềm này: nhập địa chỉ IP của camera và nhập Admin vào ô username và Nhập mật khẩu của bạn à Bấm chọn connect.

– Trên màn hình sẽ hiện lên bảng Cài đặt mạng bao gồm các mục IP, cụ thể là: Address, Subnet Mask, Gateway, DNS.

Đối với thiết bị ĐẦU GHI VANTECH VT8100E:

Lớp mạng: 192.168.0xxx.

Địa chỉ đầu ghi hình: 192.168.0.38.

Subnet: 255.255.255.0.

Getway: 192.168.0.1.

Chọn dòng Cài đặt DDNS.

Sau đó, màn hình sẽ hiện lên bảng Cài đặt DDNS.

Tiếp theo, tích vào phần kích hoạt DDNS.

Ở dòng Host name, bạn đăng nhập tài khoản bằng cách đăng ký một tên đăng nhập bất kỳ với nhà cung cấp chúng tôi ( lưu ý: Hostname này bạn cần phải đăng ký trước đó).

Đăng nhập vào trang chúng tôi bằng tên đăng nhập đã đăng ký và mật khẩu của bạn đã đăng ký.

Cuối cùng, bạn chọn Chấp nhận để hoàn tất cấu hình đầu ghi hình camera Vantech.

Bước 2: Cấu hình trên thiết bị modem( ở đây congnghehoangdanh xin hướng dẫn cấu hình trên modem Draytek

Để cài đặt cấu hình trên modern Draytek bạn vào trình duyệt web và nhập địa chỉ IP 192.168.0.2(Ip của modem draytex) và nhập địa chỉ vào trình duyệt web sẽ hiện bảng “Login to the router web configurator” và đăng nhập vào và khi đăng nhập xong sẽ hiện lên trang Vigor2700. Tùy vào dòng modern sẽ thao tác mở Port cho đầu ghi hình trên NAT hoặc VIRDUAL SERVER.

Để mở Port 81(Tùy ý bạn) cho đầu ghi hình tại NAT, ở phần mềm Vigor2700, bạn chọn NAT và chọn dòng Port Redirection và nếu thấy dòng Private IP nhập vào 192.168.0.38(IP của đầu ghi) là Private Port nhập 81 và chọn OK.

Để tắt Firewall cho phần mềm Vigor2700 thì bạn chọn Firewall và chọn General setup và ở dòng Data Filter và Call Filter chọn Disabl và chọn OK.

Thực hiện xong phần này, tiếp đến là bạn cần đăng ký thông tin DDNS trên modern bằng cách:

Chọn Applications và chọn dòng Dynamic DNS Setup, ở mục Accounts đăng nhập vào bằng cách chọn tên tài khoản người sử dụng. Lúc này màn hình hiện lên Dynamic DNS Account Setup bạn chọn bỏ tích tại ô Enable Dynamic DNS Account.

Dòng Service Provider và chọn dyndns.org.

Service Type và chọn Dynamic.

Domain name và Login name là tên tài khoản đăng nhập đã sử dụng trước đó, và chọn OK.

Kết thúc quá trình cài đặt cấu hình modern Draytek.

Như vậy, congnghehoangdanh đã hướng dẫn cấu hình đầu ghi camera vantech một cách chi tiết và dễ hiểu nhất. Hi vọng bạn sẽ nắm rõ các bước này và áp dụng nó thành công, trong việc quản lý và điều khiển hệ thống camera của bạn.

Xin cảm ơn các bạn đã theo dõi

Tham khảo các kênh thông khác:– Facebook: https://www.facebook.com/congnghehoangdanh– Website: https://congnghehoangdanh.com

Bạn đang đọc nội dung bài viết Thiết Lập Cấu Hình Dòng Switch 2960, 2960X, 2960S Chuẩn Layer 2, Hướng Dẫn 7 Bước Thiết Lập Cấu Hình Switch Cisco 2960 Nói Chung / 2023 trên website Welovelevis.com. Hy vọng một phần nào đó những thông tin mà chúng tôi đã cung cấp là rất hữu ích với bạn. Nếu nội dung bài viết hay, ý nghĩa bạn hãy chia sẻ với bạn bè của mình và luôn theo dõi, ủng hộ chúng tôi để cập nhật những thông tin mới nhất. Chúc bạn một ngày tốt lành!